Add a USES_TGZ config.in variable, so that RB1xx profiles can use it
authorFlorian Fainelli <florian@openwrt.org>
Wed, 18 Jul 2007 14:11:44 +0000 (14:11 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 18 Jul 2007 14:11:44 +0000 (14:11 +0000)
SVN-Revision: 8039

Config.in
scripts/metadata.pl
target/Config.in
target/linux/adm5120-2.6/profiles/RB1xx.mk

index 0bced5c0214bf9a0f06c54eaefaf0711f7957b3a..705c24ad2fd74e828faacf1a4f68e03f25929696 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -36,7 +36,7 @@ menu "Target Images"
 
        config TARGET_ROOTFS_TGZ
                bool "tgz"
-               default y if !USES_SQUASHFS && !USES_JFFS2
+               default y if USES_TGZ
                depends !TARGET_ROOTFS_INITRAMFS
                help
                  Build a compressed tar archive of the the root filesystem
index dbd6ccef37c8d12a044f35b5abb4fc2bc7776d1e..b4ad22e11e5e36534c6eabab54207a48b1167a73 100755 (executable)
@@ -200,6 +200,7 @@ sub target_config_features(@) {
                /squashfs/ and $ret .= "\tselect USES_SQUASHFS\n";
                /jffs2/ and $ret .= "\tselect USES_JFFS2\n";
                /ext2/ and $ret .= "\tselect USES_EXT2\n";
+               /tgz/ and $ret .= "\tselect USES_TGZ\n";
        }
        return $ret;
 }
index 31a4e590e1a339d562e2855b11779bbd246c8b27..3b9f54a7c20e70ea12647d96ac86fe906ede5990 100644 (file)
@@ -35,6 +35,9 @@ config USES_JFFS2
 config USES_EXT2
        bool
 
+config USES_TGZ
+       bool
+
 config PROFILE_KCONFIG 
        bool
 
index 9dd3de09735858fdfc322ab866a6a5d7688f8c7f..3d61cedc85bcddb8a3a5a8212d1a60449a93a726 100644 (file)
@@ -8,6 +8,7 @@
 define Profile/RouterBoard
   NAME:=RouterBoard RB1xx
   PACKAGES:=kmod-madwifi
+  FEATURES+=tgz
 endef
 
 define Profile/RouterBoard/Description